WordPress Plugin Vulnerabilities

EWWW Image Optimizer 8.7.4 - 8.9.0 - Author+ Stored XSS via 'data-script' Lazy Load Attribute

Description

The plugin does not properly sanitize and restrict a value in post content before using it to dynamically load and execute a script in the page, allowing authenticated attackers with author-level access and above to inject arbitrary web scripts that run in the session of any user who views the affected page, including administrators.

This is an incomplete fix of CVE-2026-15446: the origin and path restrictions added from 8.7.4 onward were each bypassable, so versions 8.7.4 through 8.9.0 remain affected.

Proof of Concept

Affects Plugins

Fixed in 8.9.1

References

Classification

Type
XSS
CWE

Miscellaneous

Original Researcher
Charles Vosburgh
Submitter
Charles Vosburgh
Verified
Yes

Timeline

Publicly Published
2026-11-02 (about 3 days ago)
Added
2026-11-02 (about 2 days ago)
Last Updated
2026-11-02 (about 2 days ago)

Other